Welcome to IE-LAB!

Exam Dumps
Search
Generic filters
CISCO
Search
Generic filters
CISCO

CCIE Enterprise infrastructure OSPF V3 protocol

OSPF is an important pint you must know in CCNA/CCNP/CCIE study. It is important . OSPFv3 is specified in RFC2740. There is a relationship between OSPFv3 for RIPv2 and RIPng, with some high-level similarities in OSPFv2. The most important thing is that OSPFv3 uses the same basic mechanism as OSPFv2the SPF algorithm, flooding, DR election, region, etc. The same is true for constants and variables such as timers and metrics. The other is that the similar relationship between RIPng and RIPv2 is that OSPFv3 is not backward compatible with OSPFv2. Therefore, if you want to use OSPF to route IPv4 and IPv6, you must run both OSPFv2 and OSPFv3.

Compared with OSPF v2

Get 100% accurate CCIE/ CCNP/CCNA dumps in IELAB .

In addition to the changes in LSA, some changes were also made to the OSPF program. The following changes are the most important:

1. You can view the processing of each link protocol in real time. A single link interface can have multiple IPv6 addresses at the same time.

In fact, a link can belong to multiple subnets, and two interfaces connected to the same link, but interfaces that belong to different IPv6 subnets can still communicate. OSPFv3 changes the OSPFv2 language “link” of the “subnet” and allows the exchange of packets between two areas that belong to the same link but belong to different IPv6 subnets.

2. OSPFv3 routers and network LSAs do not use IPv4 addresses. But the router’s 32-bit rotuer-id still uses ipv4 addresses, but the LSA ID works with IPv6 addresses. Allow OSPFv3 networks to cover existing OSPFv2 networks, work together, and do not interfere with each other.

3. During the establishment of neighbor relationships, OSPFv2 broadcasts and neighbors on NBMA links are identified by their interface addresses, while other types of links are discovered by RID neighbors. OSPFv3 eliminates this contradiction and allows all types The neighbor’s connection is identified by RID.

OSPFv2 packets have a link-local range and they are not forwarded by any router. OSPFv3 uses the router’s link-local IPv6 addresses (these addresses always start with FF80) as the source address and as the next hop address.

4. OSPF’s specific identity verification is removed by IPv6, using an authentication extension header, a standard authentication process.

Because of this, OSPFv3 no longer has its own authentication packet, it just uses IPv6 authentication.

Get 100% accurate CCIE/ CCNP/CCNA dumps in IELAB .

Configuration case:

CCIE Enterprise infrastructure OSPF V3 protocol detailed explanation and configuration

1.basic configuration

R1 config:

R1(config)#line console 0

R1(config-line)#exec-timeout 0 0

R1(config-line)#logging synchronous

R1(config-line)#exit

R1(config)#no ip domain-lookup

R1(config)#interface lo0

R1(config-if)#ipv6 address 2001::1/128

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#interface f0/0

R1(config-if)#ipv6 address 2012::1/64

R1(config-if)#no shutdown

R1(config-if)#exit

Get 100% accurate CCIE/ CCNP/CCNA dumps in IELAB .

R2(config)#line console 0

R2(config-line)#exec-timeout 0 0

R2(config-line)#logging synchronous

R2(config-line)#exit

R2(config)#no ip domain-lookup

R2(config)#interface lo0

R2(config-if)#ipv6 address 2002::2/128

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface f0/0

R2(config-if)#ipv6 address 2012::2/64

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface f0/1

R2(config-if)#ipv6 address 2020::2/64

R2(config-if)#no shutdown

R2(config-if)#exit

R3#config terminal

R3(config)#line console 0

R3(config-line)#exec-timeout 0 0

R3(config-line)#logging synchronous

R3(config-line)#exit

R3(config)#no ip domain-lookup

R3(config)#interface lo0

R3(config-if)#ipv6 address 2003::3/128

R3(config-if)#no shutdown

R3(config-if)#exit

R3(config)#interface f0/1

R3(config-if)#ipv6 address 2020::3/64

R3(config-if)#no shutdown

R3(config-if)#exit

R4(config)#line console 0

R4(config-line)#exec-timeout 0 0

R4(config-line)#logging synchronous

R4(config-line)#exit

R4(config)#no ip domain-lookup

R4(config)#interface lo0

R4(config-if)#ipv6 address 2004::4/128

R4(config-if)#no shutdown

R4(config-if)#exit

R4(config)#interface f0/1

R4(config-if)#ipv6 address 2020::4/64

R4(config-if)#no shutdown

R4(config-if)#exit

Get 100% accurate CCIE/ CCNP/CCNA dumps in IELAB .

2.OSPF V3 config

R1(config)#ipv6 unicast-routing

R1(config)#router ospfv3 1

R1(config-router)#router-id 1.1.1.1

R1(config-router)#exit

R1(config)#interface lo0

R1(config-if)#ospfv3 1 ipv6 area 0

R1(config-if)#exit

R1(config)#interface f0/0

R1(config-if)#ospfv3 1 ipv6 area 0

R1(config-if)#exit

Get 100% accurate CCIE/ CCNP/CCNA dumps in IELAB .

R2(config)#ipv6 unicast-routing

R2(config)#router ospfv3 1

R2(config-router)#router-id 2.2.2.2

R2(config)#interface lo0

R2(config-if)#ospfv3 1 ipv6 area 0

R2(config-if)#exit

R2(config)#interface f0/0

R2(config-if)#ospfv3 1 ipv6 area 0

R2(config-if)#exit

R2(config)#interface f0/1

R2(config-if)#ospfv3 1 ipv6 area 0

R2(config-if)#exit

R2(config)#

R2(config)#

R3(config)#router ospfv3 1

R3(config-router)#router-id 3.3.3.3

R3(config-router)#address-family ipv6 unicast

R3(config-router-af)#exit-address-family

R3(config-router)#exit

R3(config)#interface lo0

R3(config-if)#ospfv3 1 ipv6 area 0

R3(config-if)#exit

R3(config)#interface f0/1

R3(config-if)#ospfv3 1 ipv6 area 0

R3(config-if)#exit

R4(config)#ipv6 unicast-routing

R4(config)#router ospfv3 1  

R4(config-router)#router-id 4.4.4.4

R4(config-router)#address-family ipv6 unicast

R4(config-router-af)#exit-address-family

R4(config-router)#exit

R4(config)#interface lo0

R4(config-if)#ospfv3 1 ipv6 area 0

R4(config-if)#exit

R4(config)#interface f0/1

R4(config-if)#ospfv3 1 ipv6 area 0

Get 100% accurate CCIE/ CCNP/CCNA dumps in IELAB .

3. Check

R1#sho ipv6 ospf neighbor

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface

2.2.2.2           1   FULL/BDR        00:00:34    3           FastEthernet0/0

R1#

R1#sho ipv6 ospf database

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

ADV Router       Age         Seq#        Fragment ID  Link count  Bits

 1.1.1.1         969         0x80000003  0            1           None

 2.2.2.2         1342        0x80000003  0            2           None

 3.3.3.3         1342        0x80000002  0            1           None

 4.4.4.4         1298        0x80000002  0            1           None

                Net Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Rtr count

 1.1.1.1         1405        0x80000001  3          2

 2.2.2.2         1297        0x80000002  4          3

                Link (Type-8) Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Interface

 1.1.1.1         969         0x80000002  3          Fa0/0

 2.2.2.2         1407        0x80000001  3          Fa0/0

                Intra Area Prefix Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID

 1.1.1.1         969         0x80000004  0          0x2001      0

 1.1.1.1         1405        0x80000001  3072       0x2002      3

 2.2.2.2         1342        0x80000005  0          0x2001      0

 2.2.2.2         1342        0x80000001  4096       0x2002      4

 3.3.3.3         1338        0x80000003  0          0x2001      0

 4.4.4.4         1294        0x80000003  0          0x2001      0

R1#

IE-LAB provides valid materials(accurate dumps) to help you pass your CCIE. For the written, we have valid workbooks that cover all real exam questions. You can easily pass the exam, usually 7 days’ preparation in enough. For the Lab exam, we will offer valid workbooks(real exam), rack which is the same as real exam, one to one support, professional tutor and timely update.
This article is exclusively published by James from IELAB.NETWORK and cannot be reproduced without permission.
We have huge promotion going on right now, this is your best chance to get accurate written and lab materials.
Get any two Cisco written dumps for 150USD only.
Deposit 150USD now and enjoy 50% off for CCIE next-level lab.
Get 100% accurate CCIE/ CCNP/CCNA dumps in IELAB .
Please follow us if you like our articles.
visit us: http://ielab.network
Facebook: https://www.facebook.com/ielab.network/
Linkedin: https://www.linkedin.com/company/ielabnetwork/
WhatsApp: +8617782638871
Skype:live:ielab.anna

× How can I help you?