Welcome to IE-LAB!

Exam Dumps
Search
Generic filters
CISCO
Search
Generic filters
CISCO

Three minutes to learn the application of NAT address translation technology

NAT translates the private IP address into the external network IP address through the border route, and records the conversion mapping record in the NAT address translation table of the border route.When external data is returned, the route uses NAT technology to query the NAT translation table, and then replaces the destination address with the IP address of the intranet user.

Before we learned the theoretical information of NAT, we know its specific use. This time we will do a simple experiment to see how PAT (port multiplexing) is applied in reality.

A simple topology diagram with the inner network on the left and the external network on the right. Use NAT technology to access the Internet and see how to configure it.

 

First take a look at the configuration of the PC:

 

Pc0:

PC1:

Ok.

We do not need to configure the switch.

Next, configure the F0/0 interface of R0, which is our intranet gateway.

 

Router(config)#int f0/0

Router(config-if)#ip address 192.168.1.254 255.255.255.0

Router(config-if)#no shutdown

 

Ok!

Configure the IP address of the R0 and R1 connection interfaces:

R0:

Router(config)#int s1/0

Router(config-if)#ip address 10.1.1.1 255.255.255.0

Router(config-if)#no shutdown

 

R1:

Router(config)#int s1/0

Router(config-if)#ip address 10.1.1.2 255.255.255.0

Router(config-if)#no shutdown

 

Ok!

 

Next configure PAT on R0:

Router(config)#access-list 1 permit 192.168.0.0 0.0.255.255

/ / Define a convertible address.

Router(config)#ip nat inside source list 1 interface serial 1/0 overload

// Identify the external interface s1/0 as the internal global address for overload.

Router(config)#interface f0/0

Router(config-if)#ip nat inside

// Identify F0/0 as an internal NAT interface.

Router(config)#exit

Router(config-if)#int s1/0

Router(config-if)#ip nat outside

/ / Identify s1/0 as an external NAT interface

Router(config)#exit

 

\Create a default route, referring to the s1/0 interface.

Router(config)#ip route 0.0.0.0 0.0.0.0 s1/0

an examination:

Ping the external IP address with a PC:

Ping pass!

 

Verify NAT:

Show ip nat translations : Shows the details of NAT allocation.

Ping pass!

 

Verify NAT:

Show ip nat translations : Shows the details of NAT allocation.

Show ip nat statistics : Display: total number of active conversions, NAT configuration parameters, number of addresses in the address pool, and number of addresses already allocated.

End! A simple experiment that demonstrates how PAT is used and configured in the lab, and how to check for problems in the NAT process.

For more articles you can follow us on:

× How can I help you?